Wednesday, May 5, 2010

Enterprise Manger Grid Control 11g Installation on RHEL5 x86_64


On April 22, 2010 Oracle released a new version of their grid-enabled management software - Enterprise Manager Grid Control 11g. As a DBA I have come to rely heavily on this tool for the monitoring of databases, notifications and the ability to quickly diagnose and tune performance related issues (with the Diagnostics and Tuning Pack). Most of our databases are on Oracle 10gR2 but we have been planning several upgrade projects to 11gR2. Given that we are currently on Enterprise Manager 10.2.0.4 - 11gR2 databases are not supported. According to the Oracle Enterprise Manager Grid Control Certification Checker [ID 412431.1] an upgrade to release 10.2.0.5 along with required patchsets would be required in order to support 11gR2 targets, and even so some features would not be supported. I decided that instead of going to 10.2.0.5 altogether I would start testing the 11g release since it would fully support all of the databases new features. Unfortunately, since only the Linux and Solaris versions are available at the time of this writing, I could not do test the upgrade (we run EM Grid Control on AIX :( ) Anyway I went ahead with a fresh install of Enterprise Manager 11g using an existing 11gR2 database on RHEL5 x86_64.
I even did a video of the installation. I won't go into the details of the installation, suffice to say that there are tonnes of documentation on My Oracle Support site (which seems a bit overwhelming). Since 11g now uses WebLogic as the middle-tier, I was a bit apprehensive as to how the enter process would go. It wasn't difficult at all. Needless to say that be prepared to do a lot of prerequisite checks. I had to install JDK 6 before doing the WebLogic Installation. I've also compiled some notes and prerequisites to get an idea of the requirements to check for before starting the installation.
The usual disclaimer applies - DO NOT FOLLOW MY EXAMPLE TO INSTALL IN YOUR PRODUCTION ENVIRONMENT. IT'S FOR TESTING AND EDUCATIONAL PURPOSES ONLY.


Please note that my installation failed a couple of prerequisites.  My VM only had 2GB of RAM and the compat-db-4.1.25-9 package was missing.  I foolishly ignored those errors and proceeded with the installation.  The installation was successful however.





Oracle Enterprise Manager Grid Control 11g Install Notes for RHEL 5 Linux x86_64

  1. Install JDK for x86_64 Linux
  2. Install WebLogic 11gR1
  3. Install supported repository database
  4. Install Enterprise Manager System


MOS Notes:
  • Step by Step Installation of 11.1 Grid Control [ID 1059516.1]
  • How to Install Web Logic Server 10.3.2 for Installing 11g Grid Control  [ID 1063762.1]
  • Grid Control 11g: Example jdk1.6 On Linux x86_64 Install for WebLogic Server [ID 1063587.1]
  • How to check/set the database parameters housing the GC repository before GC Install/upgrade [ID 1073647.1]
  • Hard Disk requirement for 11.1.0.1.0 Oracle Management Service and Management Agent [ID 1076752.1]
  • How to apply recommended WLS patches on WLS home for 11g Grid Control Install/Upgrade [ID 1072763.1]
  • Oracle Enterprise Manager Grid Control Certification Checker [ID 412431.1]

     Oracle Documentation
Oracle® Fusion Middleware Installation Guide for Oracle WebLogic Server 
11g Release 1 (10.3.1) 
Part Number E14142-02s
Oracle® Enterprise Manager Grid Control Basic Installation Guide
11g Release 1 (11.1.0.1.0)
Part Number E15838-03



Hard Disk requirement for 11.1.0.1.0 Oracle Management Service and Management Agent



Platform
OMS (ulimit)
Agent (ulimit)
RAM
Hard Disk for 11g OMS
Hard Disk for Middleware Home
Hard Disk for Standalone Management Agent
Linux x86-64 (64 bit)
4096 MB
1024 MB
3 GB
1 GB
6 GB
850 MB

Package Requirements for Oracle Management Service

Table B-1 describes the packages required on different operating systems for installing an OMS:
Table B-1 Package Requirements for Oracle Management Service


Operating System
Package
Red Hat Enterprise Linux 5.x
Oracle Enterprise Linux 5.x
  • rng-utils-2
  • make-3.81
  • binutils-2.17.50.0.6
  • gcc-4.1.1
  • libaio-0.3.106
  • glibc-common-2.3.4-2.9
  • compat-libstdc++-296 -2.96-132.7.2
  • libstdc++-4.1.1
  • libstdc++-devel-4.11
  • setarch-1.6-1
  • sysstat-5.0.5-1
  • compat-db-4.1.25-9



Package Requirements for Oracle Management Agent

Table B-2 describes the packages required on different operating systems for installing a Management Agent:
Table B-2 Package Requirements for Oracle Management Agent


Operating System
Package
Red Hat Enterprise Linux 5.x
Oracle Enterprise Linux 5.x
  • make-3.81
  • binutils-2.17.50.0.6
  • gcc-4.1.1
  • libstdc++-4.1.1

Library Requirements for Oracle Management Service

Table B-3 describes the libraries required on different operating systems for installing an OMS:
Table B-3 Library Requirements for Oracle Management Service


Operating System
Library
Red Hat Enterprise Linux 5.x
Oracle Enterprise Linux 5.x
GLIBC-2.5-12

No comments:

Post a Comment

IOUG Collaborate 14

IOUG Collaborate 14
IOUG Collaborate 14 Las Vegas